16:23 

VMWare ESXi 5.5 with 2 GB RAM

Hikedaya
В Dash'e под Chronostasis'ом.

Это извращение. Поскольку esxi 5.5 требует минимум 4 ГБ памяти, лучше просто добавьте памяти в хост-систему. Если же такой возможности нет...
1. Загрузить хост с диска установки esxi 5.5
2. На стартовом экране приветствия нажать Alt+F1, чтобы попасть в консоль.
3. Войти в систему, используя в качестве логина root с пустым паролем.
4. Сменить текущий каталог на /usr/lib/vmware/weasel/util
cd /usr/lib/vmware/weasel/util
5. Удалить скомплимированный скрипт установки, называется он upgrade_precheck.pyc:
rm upgrade_precheck.pyc
6. Сбросить неубиваемый обычными методами флаг Read Only с файла скрипта установки (файл upgrade_precheck.py)
cp upgrade_precheck.py upgrade_precheck.py.new
rm upgrade_precheck.py
cp upgrade_precheck.py.new upgrade_precheck.py
rm upgrade_precheck.py.new
chmod a+w upgrade_precheck.py

7. Отредактировать файл скрипта:
vi upgrade_precheck.py
В нем нужно найти параметр MEM_MIN_SIZE и прописать в него следующее:
MEM_MIN_SIZE = ((n * 1024 - 32) * SIZE_MIB
где n - количество гигабайт памяти в хосте.
Сохранение файла: :wq
8. Убить из памяти запущенный экземпляр инсталлятора (найти PID процесса /bin/python weasel/main.py):
ps -c | grep weasel
kill PID_of_/bin/python weasel/main.py

После выполнения восьмого пункта инсталлятор будет перезапущен автоматически с уже новыми требованиями по памяти.

@темы: VMWare, Virtualization

URL
   

Записная книжка

главная